[BUG] Détérioration des liens d'images avec variables GET


12 Janvier 2013
310
81
43
Niveau
170
Clan
100% Farm
Niveau du clan
18
Rang de Clan
Chef adjoint
#1
Bonsoir,

Je me demandais pourquoi les images de clash of stats ne fonctionnaient plus. Après m'être rendu compte que le lien de l'image passait par une redirection via https://www.clashofclans.fr/proxy.php modifiant les caractère spéciaux du lien, j'ai tenté d'enlever la fin du lien de l'image, qui contient des variables GET. Et ça a marché, l'image s'affiche! Un test vaut mieux qu'un long discours :

Code:
[img]https://www.clashofstats.com/signatures/clans/9YUQLR9R?lng=fr&color=blue&size=large[/img]


Code:
[img]https://www.clashofstats.com/signatures/clans/9YUQLR9R[/img]


Serait-il possible de régler ce problème ?
Merci d'avance

EDIT : J'ai fais un petit test avec un lien vers une page web avec variables get, et il n'est pas détérioré. Il semble que les liens normaux ne passent pas par proxy.php, ça ne concerne que les images.
https://www.ecosia.org/search?q=clash+of+clans
 
Dernière édition:

Menerv

Administrateur
Membre du Staff
31 Decembre 2012
7 421
5 306
198
30
Ile de France
www.clashofclans.fr
Niveau
149
Clan
Les Kikous
Fiche du clan
https://www.clashofstats.com/fr/clans/les-kikous-LPP2YPP
Niveau du clan
13
Rang de Clan
Ainé
Ligue
Champion II
#2
Bonjour,

Après m'être rendu compte que le lien de l'image passait par une redirection via https://www.clashofclans.fr/proxy.php
Le forum utilise un proxy interne pour gérer l'affichage des images. Cela est nécessaire car nous utilisons le protocole HTTPS afin de chiffrer la communication entre vos navigateurs et nos serveurs. Du fait de cet usage, si un membre souhaiterais afficher une image depuis un site n'utilisant pas le HTTPS, vos navigateurs afficheraient systématiquement une alerte de sécurité à chaque fois qu'une telle image devrait être affichée.

modifiant les caractère spéciaux du lien, j'ai tenté d'enlever la fin du lien de l'image, qui contient des variables GET. Et ça a marché, l'image s'affiche! Un test vaut mieux qu'un long discours :
Pour moi ça fonctionne parfaitement, il y a parfois des caches qui ne sont pas mis à jour assez rapidement et cela peut entraîner des petits soucis d'affichage, mais cela se résout tout seul dans le temps.
 
12 Janvier 2013
310
81
43
Niveau
170
Clan
100% Farm
Niveau du clan
18
Rang de Clan
Chef adjoint
#3
Ah tiens, en effet, l'image s'affiche à présent. En tout cas, j'en avais parlé sur discord, je ne suis pas le seul qui se soit fait avoir.
Sujet clôt, merci de l'explication Menerv!